Results 1 to 10 of 10

Thread: 1.59 Still can't play From Hell

  1. #1

    1.59 Still can't play From Hell

    I've always ended up playing sandstorm but I finally tried "from hell" and i still get the mission fail. The pilot gets shot trying to escape (even though he is standing still).

    I have 1.59 and I see that it's fixed in the change log but it's not. I even deleted the pbo and 1.59 added it but still not working.

    I searched but get people talking about other things, or before patch 1.57.

    Anyone know how i can fix it? Or tell me what the problem is and i can maybe fix it on my end with whatever is broken.


    Thanks

  2. #2
    CWR² Chief Beta Tester OMAC's Avatar
    Join Date
    Dec 30 2010
    Location
    Firebase Zulu
    Posts
    1,792
    I played through it for the first time a month ago using either 1.59 or a 1.60 beta, and had no trouble. Keep trying, you'll get it. Please post the entry in the changelog that you are referring to.

  3. #3
    * Fixed: Missions: 06 From Hell, task "Locate the pilot" always failed.

    http://www.armaholic.com/page.php?id=12978

    That is the page that has the changelog from 1.57


    I am wondering, is it possible to install patch 1.59 without ever installing 1.57? Because looking at the change log, I notice that when vehicle crew is killed, the vehicle gets unassigned as a target. But my guys keep shooting at empty vehicles. So I wonder if I somehow skipped a patch. But I thought you can't get patches until previous patch has been applied. If i have all patches then the pilot fail would not happen since it was already fixed.

    If I am getting a fail message because the pilot keeps getting shot, then I can keep trying all I want cause it won't fix itself. I put it in editor and played as one of the guards and when the game starts the lead says "The pilot is trying to escape, kill him". But if I spawn as pilot they don't shoot.
    Last edited by victim913; Nov 29 2011 at 06:19.

  4. #4

  5. #5
    CWR² Chief Beta Tester OMAC's Avatar
    Join Date
    Dec 30 2010
    Location
    Firebase Zulu
    Posts
    1,792
    As far as I know, A2 and OA patches are cumulative, so if you have 1.59 installed, you should have all the 1.57 fixes even if 1.57 itself was never installed.

    The first thing I would do would be to revert to beginning of From Hell and replay using a clean 1.59. Then I'd install most recent 1.60 beta patch, revert again and play just to make sure there are no problems with the beta, and report back. We need as much testing as possible with the 1.60 betas right now. If you still can't get through, then file a bug.

  6. #6
    I actually did that. I tried "from hell" from the begining. I was actually restarting and replaying the entire campaign.

    When it didn't work, I remembered seeing a patch that said it was fixed. so i looked at the latest patch I had which was 1.59. I looked at all the folders in Expansion/addon/ etc. and I saw that most of the files had been modified the same day I got the patch. Which means 1.59 was already applied.

    I went back and ran the patch exe and re-updated the patch.
    I had the same problem. I restarted from the begining of from hell with same result.

    Then I went and deleted the mission pbo from Expansion/addons. I reapplied the patch again. It gave me a new mission pbo and again, same problem.

    Then I opened the mission from hell and I compared every file from the new "missions pbo" for from hell with the old version of from hell. Everything was the same. They all had the same things. File sizes were the same, dates were the same. I looked at the fsm files and they all matched.

    I was wondering if the files in the ca folder have anything to do with it.

    If i use the beta, I can't play the mission without starting from begining of campaign.
    However I have been unpacking things and trying the mission in the editor and I get the same result. I even tried figuring out what the problem with the mission was. It seems that the pilot is not the right distance from the 2 markers. That's what causes the guards to say he is trying to escape. But if I play the pilot they don't shoot.

    Should I reinstall OA? I hate to do that. I know I have arma2 backed up but not sure about OA. If I do have OA backed up could I just delete the mission pbo and replace it with the backup, then apply patch again? Or should I delete all OA files before applying the patch again.

    My main concern is that if I do put a fresh OA, will I have to apply all patches or just the last one 1.59?

    Thanks for the help btw.

  7. #7
    CWR² Chief Beta Tester OMAC's Avatar
    Join Date
    Dec 30 2010
    Location
    Firebase Zulu
    Posts
    1,792
    This is quite confusing, but I really don't think that you need to bother with disassembling the pbo and examining everything in the editor. In fact, I would avoid that at all costs, as it is most likely a waste of your time. No one else has reported a problem with this mission in quite a while, so it is doubtful that you have encountered a real bug, but it is indeed possible. The simplest thing to try is install the latest OA beta, and then revert to the start of From Hell and replay. But before trying that, I would ensure the integrity of all game files.

    Given that you have messed around extensively with the 1.59 game files, it may be better to uninstall OA completely and reinstall, which I know is a major hassle. That may not be necessary if you have taken care to only depbo and otherwise edit COPIES of game files, and left all game files untouched in their original locations. I would NOT do this:

    If I do have OA backed up could I just delete the mission pbo and replace it with the backup, then apply patch again?
    I will try and find time over the next few days to revert back to Open Season, crash land, and play From Hell using 1.59. But, again, I played through not that long ago using either 1.59 or a 1.60 beta and had no issues. I had some trouble finding the pilot as I remember, but he never tried to escape. But given that the triggers at the end of the mission are somewhat complex, and that a bug involving the end of the mission did previously exist, and the fact that not very many people play From Hell given that failure of Open Season is required to do so, all add up to mean that another bug in From Hell may exist.
    Last edited by OMAC; Dec 1 2011 at 01:22.

  8. #8
    This is not the first time when someone is having problems with From Hell-mission: http://dev-heaven.net/issues/16037.

    I went all the trouble of failing my mission in Open Season, just to get to From Hell to reproduce the issue and I found nothing described in that ticket, so I would prefer someone else to try to reproduce this time. Thank you OMAC if you are willing to do that.

    Since From Hell is available only after bad success in Open Season, not many players ever see it or want to play it. So I would not be surprised to find any bug there that has avoided public attention. However I would like to know if victim913 has mods installed since that has been a reason for so many anomalities in this subforum.

  9. #9
    CWR² Chief Beta Tester OMAC's Avatar
    Join Date
    Dec 30 2010
    Location
    Firebase Zulu
    Posts
    1,792
    I reverted to Open Season and failed it to start From Hell again. Will play it tonight. Seems to me that problems in that ticket were related to end mission cheat and/or corrupted savegames or profile, and thus are not repeatable.

    ----------------------------------

    I played it using beta 86705 (Veteran), and had no problems. All was normal. The pilot was lying on floor of building in compound, as usual. After mowing down enemy in street near compound, by the time I got to the compound, all enemy inside it were dead. No enemies were around even when I was holding the LZ. It seemed very easy, a little too easy. But fun.

    My guess is that victim913 has corrupted game files.
    Last edited by OMAC; Dec 1 2011 at 01:22.

  10. #10
    Private First Class britishlegion's Avatar
    Join Date
    Dec 6 2011
    Location
    Lincolnshire, United Kingdom
    Posts
    19

    Ah i see

    Thanks Mate, for posting this now i know what to do with this MOD. Appreciate it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •