Results 1 to 9 of 9

  Click here to go to the first Developer post in this thread.  

Thread: arma 2 bad serial number via steam?

  1. #1

    arma 2 bad serial number via steam?

    i've owned arma 2 and oa for a few years now, and i play oa a fair bit but when i reinstalled arma after i formatted my computer i now cant play arma2 but i can play arma2 oa??

    this is the message that i get.

    bad serial number given in setup

    any help?

    steam: HGG-Beer

  2. #2
    I'm having the exact same problem, just reinstalled W7 and while Arma2 works, Arma2 OA and CO won't

    I have tried copying the A2 key in the registry and adding it to the OA folder, did not work. I've also tried running it as an admin to no avail. I'm using Steam too BTW.

  3. #3

  4. #4
    Quote Originally Posted by W0lle View Post
    Sorry, but is it really asked too much to spend at least a few minutes with using the forum search before starting yet another thread about the same problem:
    I personally have searched, found those threads, but non of that has helped. Reinstalled, deleted registry, copied A2 reg key to OA key, and ran as admin as per all the solutions to those threads.

    So somehow my computer just decided to be special

  5. #5
    Try verifying integrity of game cache.

  6. #6
    Quote Originally Posted by solidsnake2384 View Post
    Try verifying integrity of game cache.
    Forgot to mention I tried that first thing lol.

  7. #7
    I tried uninstalling the game, deleting all symbolance of files on my HD, and wiped all OA files from the registry the reinstalled it, and guess what, it worked! I did this once already before, but I think I tried loading CO first while this time I just started OA to allow steam to initialize everything.

  8.   This is the last Developer post in this thread.   #8
    start STEAM via "run as administator"
    try run game

    if it fails restart computer (delayed service write up by STEAM or w/e)

    try again, if that fails change source server in network settings, restart steam and try again

  9. #9
    Had the same problem. It was solved as Dwarsen sed, by running steam as administrator
    Last edited by Tuskusson; May 23 2011 at 08:58. Reason: spelling error

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •