Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Squad.xml Editor - Open source webtool

  1. #1
    Private First Class TomNedry's Avatar
    Join Date
    Dec 18 2006
    Location
    Vienna, Austria
    Posts
    39

    Squad.xml Editor - Open source webtool

    While managing our active community at www.pzgrenbtl417.eu i had to edit our "squad.xml" about once a week. Not that much work you may think, but some sort of annoying and error-prone...

    So i decided to write a small web-based tool and as i found it somewhat useful to me i like to donate it to the community under the GPL3 licence.

    Download-Link: http://arma.airpressuretendency.net/...a_squadxml.htm


    Some screenshots:







    UPDATE: 06apr2011

    Remark: To show your "squad.xml" on a website you'll need a DTD and XLS file too. Look here: http://community.bistudio.com/wiki/squad.xml

    UPDATE: 08apr2011

    Minor fix. Download file updated.

    UPDATE: 31oct2011

    Added: non-ASCII characters in textfields will be deleted to keep XML strict
    Changed: New download URL

    Update: 03nov2011

    • Add UTF-8 support
    • Removed "Auto-removes all non-ASCII characters"
    • Readme.txt adopted
    Last edited by TomNedry; Nov 3 2011 at 18:17. Reason: Update

  2. #2
    Awesome -thanks!
    Last edited by HunterTX; Apr 4 2011 at 20:57.
    21st Century Warfare ~
    A PvP Arma2/CO Tourny - 21CW.net

  3. #3
    Thanks for sharing Tom, now i know how you changed them so fast everytime^^

    Download mirrored on Arma2Base.de
    http://www.arma2base.de/include.php?...contentid=3363

  4. #4
    hmm getting an error here
    Parse error: syntax error, unexpected '.' in forum/squadxml/squadxml.php on line 28
    Last edited by =WBG=ati; Apr 5 2011 at 11:52.

  5. #5
    Private First Class TomNedry's Avatar
    Join Date
    Dec 18 2006
    Location
    Vienna, Austria
    Posts
    39
    Author of the Thread
    Quote Originally Posted by =WBG=ati View Post
    hmm getting an error here
    Parse error: syntax error, unexpected '.' in forum/squadxml/squadxml.php on line 28
    Fixed and download updated...

    Occured on webservers with another port than 80 only.

    Download the new archive or just go to line 28 in "squadxml.php" and replace

    Code:
    $_SERVER["SERVER_PORT"]..$path_parts['dirname'];
    by

    Code:
    $_SERVER["SERVER_PORT"].$path_parts['dirname'];
    Last edited by TomNedry; Apr 5 2011 at 17:41.

  6. #6
    Private First Class TomNedry's Avatar
    Join Date
    Dec 18 2006
    Location
    Vienna, Austria
    Posts
    39
    Author of the Thread
    Remark: As asked several times via PM: To show your "squad.xml" on a website you'll need a DTD and XLS file too. Look here: http://community.bistudio.com/wiki/squad.xml

  7. #7
    Private First Class TomNedry's Avatar
    Join Date
    Dec 18 2006
    Location
    Vienna, Austria
    Posts
    39
    Author of the Thread
    Minor fix and download updated...

    To patch manually just go to your "squadxml_save.php" and search for line 61. Remove:

    Code:
    require_once("/squadxml.php");
    and set instead:
    Code:
    require_once("squadxml.php");

  8. #8
    works great but not the security like .htacces and .htpasswd

  9. #9
    Private First Class TomNedry's Avatar
    Join Date
    Dec 18 2006
    Location
    Vienna, Austria
    Posts
    39
    Author of the Thread
    Quote Originally Posted by blade73 View Post
    works great but not the security like .htacces and .htpasswd
    What's the problem with ".htaccess" etc. ?

  10. #10

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •