Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Bulldozer (OA.exe) stuck on "preparing surface materials" after sat/mask import

  1. #1

    Bulldozer (OA.exe) stuck on "preparing surface materials" after sat/mask import

    Ok, got the basic stuff done, work folder setup using OA.exe. (Copied the folders in, depbo'd the 3 from DTA into P:\root (Bin, Core, Languagecore) etc, presumably it was all good because I could fire up buldozer fine with just the elevation data in place (XYZ grid imported)

    So, got my Sat_Lco png & mask ready, mask was just a single layer, using brown. I simply wanted to be able to see the elevation with the satelite layer to see in 3d how it was lining up. Going over the background image method through visitor wasn't really ideal for this.

    So, imported the sat & mask (legend & layers.cfg also ready). Import goes fine. So, launch buldozer. It does it's thing converting the pngs to paa without a hitch, but, it just doesn't start afterward. The "Preparing surface materials" text shows, the line goes back and forth for a bit and then just stops. Doesn't crash, CPU is still showing 50% (assume 1 core maxed), but buldozer never actually opens the map.

    FWIW, map grid was 2048,
    cell size 6
    area 12288m X 12288m, sat & mask both the same.
    Texture size 48m
    Sat grid 64, sat segment 512.

    The one texture & rvmat (from a tutorial on here) used in the layers.cfg is residing in p:\myprojectname\mapname\data The layers folder is in data, with the thousands of png, paa & Rvmat files present. Opening some of the paa's up they look fine.

    Map pew is in P:\projectname the sat & mask etc were in the source folder.

    Any ideas of where to start looking for a cause greatly appreciated.

    Should I revert back to plain Arma2 used for buldozer? Tried reimporting twice, but after an hour or so each same end result. Double then triple checked through the tutorials and my file structure, and didn't see anything out of place.

    And an unrelated question: Since I imported the elevation data using an xyz grid, do I still need a pdl file? I only saw them mentioned in conjunction with greyscale png elevation imports. Without one, prior to the sat import troubles, the elevations looked fine in buldozer, just hard to judge things when it's all plain white. I should have known I'd turn an "easy" import of the satelite imagery into a multi hour fiasco.
    Last edited by Baron von Beer; Dec 18 2010 at 04:27.

  2. #2
    Try waiting. With me it takes ages, it even says the program is not responding, then, out of nowhere, its there.

  3. #3
    Hm...

    i had that problem too as i mentionend in another thread. When i used arma2OA from version 1.55 or 1.56 and the files from dta i was not able to get bulldozer running in visitor. My solution was: deinstall arma20a, install and patch to 1.54 copy the desired files to my pdrive etc.... then i patched the game to i.56. That leaves the files on p:\ untouched
    Make a backup of your needed 1.54 files for the future.
    I think most of us are not using the latest arma2oa.exe for their buldozer because they have setup their p:\ drive earlier.

  4. #4
    Will give it a shot, I am indeed using OA 1.56. Thanks Beton!

  5. #5
    CWR² Developer shezan74's Avatar
    Join Date
    Jun 29 2009
    Location
    Quarto d'Altino - Venice - ITALY
    Posts
    436
    I've noticed the same issue moving from 1.54 to 1.56. Looking on DEV HEAVEN for reports...

  6. #6
    Ok.. so at the moment its: playing with version 1.56, visitor needs 1.54 not higher...but oxigen does not have any problems with 1.56

  7. #7
    CWR² Developer shezan74's Avatar
    Join Date
    Jun 29 2009
    Location
    Quarto d'Altino - Venice - ITALY
    Posts
    436
    Quote Originally Posted by Beton View Post
    Ok.. so at the moment its: playing with version 1.56, visitor needs 1.54 not higher...but oxigen does not have any problems with 1.56
    By the way bulldozer is not frozen. It's really slow after loading objects, and freezes for a couple of seconds or some minutes, but after this time it will come back alive and fully functional.

    EDIT: Issue reported on DH http://www.dev-heaven.net/issues/16047
    Last edited by shezan74; Dec 18 2010 at 12:31.

  8. #8
    Yeah, I launched buldozer before going to bed and let it run overnight and at some point it finally started. No idea how long it actually took, but I waited a full 15 minutes for it to start before initially posting the issue. Though it loaded, there were more issues waiting with open arms.

    When I checked it this morning after it did finally load, the satellite texture still wasn't present, the terrain was a flat dark gray (not like the whitish pre-sat import, but near black) and there was very strange & delayed lighting. Like thick fog staring into a spotlight, and the lighting would slowly adjust over ~20 seconds each time I changed pitch and rotate. I can only assume that though it made it to 3d, it was still having some serious issues. (There was nothing close to resembling this strange lighting & fog when I went to 3d prior to the sat import, and buldozer loaded within ~5 seconds.

    Hoping to be able to give 1.54 a shot tonight and see if that does the trick. Will post results when I do. And again, thanks for all the info. Very much appreciated.
    Last edited by Baron von Beer; Dec 18 2010 at 16:22.

  9. #9
    1.54 does fix the load time. FWIW, I grabbed OA Beta 72967 and was able to use the files within that, don't need to do a whole reinstall. (Download beta patch, extract it. Then use 7zip, etc to extract the exe that was in the zip file. Then extract the exe that is extracted from the initial exe, might have to manually open 7 zip and tell it to extract, at that point it no longer had the right click context menu, but it will still extract it. Then the ultimate path is ARMA2_OA_Build_72967\.rsrc\0\RCDATA\ALL the oa.exe is in there, and then expansion\beta has the dta folder)

    With those files, it loads in ~30 seconds, much better than >15 minutes. Still no textures though, the terrain is still dark gray. Just to verify, my sat_LCO and mask were 8 bit RGB png files, is this correct? Next guess, in Visitor if I hit the "terrain types" button (upper right, bottom row, 2nd to left) the map shows as all blue. This wouldn't mean water by any chance would it, and if so, how might I change that? I was under the impression that was done automatically to anyplace <0m alt, which shouldn't be an issue for me. Believe my lowest point, and visitor shows this, is ~1450m

    Those are my only 2 guesses so far, as the data\layers folder seems to have everything in it, bunch of mask & sat .paa files, and rvmats.
    Last edited by Baron von Beer; Dec 19 2010 at 13:59.

  10. #10
    Hm... if you see terrain in buldozer but without textures (or only dark) you may want to delete the contents of your layers folder and do a complete sat and mask reimport with your new Arma2oa files.
    Maybe you just open some of the .paa files in you layers-folder and look if they show some sat or some mask... you can also open some of the rvamt files and look where they are pointing at....

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •